Build.sbt error when running tutorial

I am new to Java/Play framework/sbt and I encounter an error when running this tutorial:
https://www.playframework.com/documentation/2.8.x/HelloWorldTutorial

MacOS Mojave 10.14.6
IntelliJ Idea community edition 2020.3.2
default sbt version 0.13.18

no modification, just downloaded and unzipped here

  1. It does not resolve view from app/views/
    play-samples-play-java-starter-example/app/controllers/HomeController.java:30:13
    java: cannot find symbol
    symbol: variable index
    location: class controllers.HomeController
  2. when I try to run ‘sbt clean’ there’s error in build.sbt
    [error] [play-samples-play-java-starter-example/build.sbt]:14: illegal start of simple expression
    [error] [play-samples-play-java-starter-example/build.sbt]:24: ‘)’ expected but eof found.

I tried searching on stackoverflow and it seem like a sbt version issue, but I am not sure since ‘sbt sbt-version’ cannot work in project folder. Please help.

Finally found the cause. There might be conflict between my installed sbt and the sbt distribution in tutorial. I delete the sbt-dist ans sbt, sbt.bat to use installed sbt instead and it worked.

That is a rather old version of sbt and it is no longer supported. I suggest you upgraded your default sbt version to a newer one.