Consistent delay of 5s observed in publishing messages

We observe a consistent delay of 5 seconds when event publishig happens. What configuration can be used to tune this? we already reduced and refresh-interval for cassandra query , still the same delay…
how else can it be tuned?

Hi @shrutichandra,

I guess you’re using Lagom (since you mentioned the setting but it’s unclear what persistence plugin you are using (Cassadnra or JDBC). The high-level answer is independent of the plugin you use but the detail of the setting name is plugin specific.

The reason why the publishing to Kafka is not immediate is that there are two different processes (likely running on different machines) writing and reading from the event journal. On top of that, the process polling data from the journal is not immediate but a periodic poll. On top of it all, the polling often ignores very recent events (e.g. any event that happened in the last 5 seconds`) in case there’s data pending synchronisation between DB nodes or transactions in flight.

Each persistence plugin ships with good enough settings for the general use case but you may tune them to your specific needs. Of course, the features and settings for each plugin differ.


Hey @ignasi35,

Thanks for your explanation.
We are using cassandra as persistence plugin.

we reduced the to 10ms, so it is faster now.
It is just that the correct configuration is not so easy to find and so we ended up spending a lot of time tweaking the parameters.