Error while running sbt command

I am following a book n Lagom.
It asks to run command:

sbt -Dsbt.version=0.13.16 new https://github.com/lagom/lagom-scala.g8

When I do this, I get error:

Error during sbt execution: sbt version cannot be empty (omit declaration to use the default)

What is missing here?

Quite probably the book you’re reading is a bit outdated already.

Most recent stable versions of Lagom support sbt v1.x

If you have the latest sbt installed you only need to

sbt new lagom/lagom-scala.g8

Find instructions in the official documentation.

2 Likes

You will get this error if you put a space after the = and before the 0.13.16. Omit the space.

(Or follow Ivano’s advice.)

1 Like