Failure-detector.acceptable-heartbeat-pause does not seem to work

Sorry, ignore this for now. Maybe I made a mistake.

Hi I am running a cluster in AWS EC2 enviroment. I was trying to increase acceptable-heartbeat-pause of cluster failure-detector, by doing the following.

akka.cluster {
  failure-detector {
    heartbeat-interval = 2s
    threshold = 12.0
    acceptable-heartbeat-pause = 8s

But I am still receiving heartbeat warning below:

heartbeat interval is growing too large for address akka.tcp://cluster_name1@ 3699 millis

It seemed the settings was not gotten applied. Looking at the source code I expected to get warning when interval is bigger than 5000 millis?

akka.remote.PhiAccrualFailureDetector {
if (interval >= (acceptableHeartbeatPauseMillis / 3 * 2) && eventStream.isDefined)
                s"heartbeat interval is growing too large for address $address: $interval millis"))
          oldState.history :+ interval


Then it might not use the config that you defined. Did you place it in application.conf or in the config that you define when starting the ActorSystem.

@patriknw It was my mistake. It is working now. Thanks.