Kamon with GuiceOneAppPerSuite based test should have no instrumentation

We want to use Kamon in our play application so we have added,
as plugin
addSbtPlugin(“io.kamon” % “sbt-kanela-runner-play-2.7” % “2.0.2”)
and as dependency
“io.kamon” %% “kamon-bundle” % “2.0.1”,
“io.kamon” %% “kamon-prometheus” % “2.0.0”,

This is producing the metrics we want but the instrumentation is always activated for a GuiceModule

As a result we get In our Guice based tests following stacktrace:
java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask@14f57933 rejected from java.util.concurrent.ScheduledThreadPoolExecutor@14558202[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 1]
at java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(ThreadPoolExecutor.java:2063)
at java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:830)
at java.util.concurrent.ScheduledThreadPoolExecutor.delayedExecute(ScheduledThreadPoolExecutor.java:326)
at java.util.concurrent.ScheduledThreadPoolExecutor.schedule(ScheduledThreadPoolExecutor.java:533)
at kamon.module.ModuleRegistry.scheduleMetricsTicker(ModuleRegistry.scala:189)
at kamon.module.ModuleRegistry.stop(ModuleRegistry.scala:131)
at kamon.ModuleLoading.stopModules(ModuleLoading.scala:73)
at kamon.ModuleLoading.stopModules$(ModuleLoading.scala:72)
at kamon.Kamon$.stopModules(Kamon.scala:19)
at kamon.instrumentation.play.GuiceModule$KamonLoader.$anonfun$new$2(GuiceModule.scala:26)

How can we prevent Kamon to be used in our tests?
Tried on the command line
-Dkamon.auto-start=true
Tried in application.test.conf
play.modules.disable += kamon-akka

One solution that is working is excluding the bundle dependency in tests.
It is not an elegant solution but something like:
fullClasspath.in(Test) := fullClasspath.in(Test).value.filterNot(_.data.getName.contains(“kamon-bundle”))
did the trick