Lagom wesocket message

lagom wesocket message size default is 64k at server side, how to increase it?

hi @prateek166,

you need to increate the maxLengthsetting. Lagom is built on top of Akka and Play and there are multiple settings Lagom simply delegates. In this case, you need to increase the value of play.server.websocket.frame.maxLength. See more at https://www.playframework.com/documentation/2.8.x/SettingsAkkaHttp#Configuring-the-Akka-HTTP-server-backend

Regards

1 Like

Keep in mind that multiple settings altering the Server (not the Application) are ignored in DevMode.

Play (and Lagom) processes are a combination of two pieces: an HTTP Server and the Application. Due to limitations in DevMode, multiple settings affecting the Server half are ignored in DevMode and will only be honored in Production and maybe Test modes.