Play sbt-plugin for sbt 1.3.0 and scala version 2.11

Hello I currently upgrading to sbt 1.3.0 and my project is currently on scalaVersion 2.11.
I would like to use the sbt-plugin but the directory seems to only have 2.10 or 2.12. In the 2.10 dir there is 2.5.15, but if I specify the versions in plugins.sbt:
addSbtPlugin("" % "sbt-plugin" % "2.5.15", sbtVersion ="0.13",scalaVersion = "2.11")
and have scalaVersion := 2.11.12 the i get this conflict error:

Modules were resolved with conflicting cross-version suffixes in ProjectRef(//my project path io.spray:spray-json _2.10, _2.12
[error] java.lang.RuntimeException: Conflicting cross-version suffixes in: io.spray:spray-json

I dont have spray-json explicitly in my build.sbt and it doesn’t seem to appear in sbt evicted out put.

The Scala version used by the sbt plugin is independent of the Scala version used by the libraries within your own project. For sbt plugins, the Scala version depends on the version of sbt you are using: Scala 2.10 for sbt 0.13.x, and Scala 2.12 for sbt 1.x. There was never an sbt version that used Scala 2.11.

Ordinarily, you should not need to specify the sbtVersion or scalaVersion in your plugin dependency. Write it like this:

addSbtPlugin("" % "sbt-plugin" % "2.5.15")

sbt will figure out the rest automatically :slightly_smiling_face:

Hello Tim,

Thanks for the help, however if I try to let sbt figure it out automatically with just:
addSbtPlugin("" % "sbt-plugin" % "2.5.15")
I receive this error:
sbt.librarymanagement.ResolveException: Error downloading;sbtVersion=1.0;scalaVersion=2.12:2.5.15
From your reply I assume the scalaVersion is set to 2.12 because the sbt is 1.3.0.

The error could could come from a missing resolver. The current resolved locations are:

Edit: I looked into the links above and this seems to be where sbt-plugin resides
If this is the location for most recent releases of sbt-plugin then it seems 2.5.15 is only available for sbt 0.13

You are correct, If you want to use sbt 1.x to build your project, you have to be on a play version greater than or equal to 2.6.0.

1 Like

This. You need to use at least Play 2.6.6 as documented here:


That’s the sbt 0.13.x version of the plugin. The 1.x versions are found here: