Possible reactive-app bug? - minimum sbt-reactive-app version is 1.7.0, docker image was built using 1.6.1


(Joo) #1

Hi all,

Suddenly I am getting this error whenever I try to deploy my lagom services using CircleCi.
I did not change anything in the deployment configuration. Possible some issue with the reactive-app?

#!/bin/bash -eo pipefail
set -x
source $BASH_ENV
./kubernetes/generate-k8s.sh
+ source /tmp/.bash_env-5c5c4f601e53d3000872ab18-0-build
++ export SHORT_GIT_HASH=9094f83
++ SHORT_GIT_HASH=9094f83
+ ./kubernetes/generate-k8s.sh
++ dirname ./kubernetes/generate-k8s.sh
+ DIR=./kubernetes
+ export service_cassandra=_cassandra._dev.service.consul
+ service_cassandra=_cassandra._dev.service.consul
+ export service_kafka=_kafka._dev.service.consul
+ service_kafka=_kafka._dev.service.consul
+ secret_key=xxxyzz
+ SVC_FILE=service.yaml
++ cat ./kubernetes/services.list
+ SERVICES='someserviceA someserviceB'
+ '[' -z 'someserviceA someserviceB' ']'
+ echo 'Generating kubernetes resources for someserviceA someserviceB'
Generating kubernetes resources for someserviceA someserviceB
+ for s in $SERVICES
+ mkdir -p ./kubernetes/someserviceA
+ rp generate-kubernetes-resources us.gcr.io/xxxyzz-169801/someserviceA-impl:1.0.2-9094f83 --generate-pod-controllers --generate-services --env JAVA_OPTS=-Dplay.http.secret.key=xxxyzz --namespace silver-alpha --pod-controller-replicas 3 --external-service cas_native=_cassandra._dev.service.consul --external-service kafka_native=_kafka._dev.service.consul
[error, com.lightbend.rp.reactivecli.Main$] Failed to obtain Docker config for us.gcr.io/xxxyzz-169801/someserviceA-impl:1.0.2-9094f83, minimum sbt-reactive-app version is 1.7.0, docker image was built using 1.6.1
Exited with code 1

(Joo) #2

Upgrading the plugin to the below resolved this issue, but is this expected?

addSbtPlugin(“com.lightbend.rp” % “sbt-reactive-app” % “1.7.0”)


Cluster fail with error "Akka version MUST be the same across all modules of Akka that you are using,"
(Eugene Yokota) #3

reactive-cli (rp) 1.7.0 requires some of the information available in sbt-reactive-app 1.7.0.
How is reactive-cli installed?


(Joo) #4

hello @eed3si9n thanks for the reply! My CircleCi builds download the Reactive CLI using the below command:

wget -qO - https://downloads.lightbend.com/rp/keys/bintray-debian | sudo apt-key add - && echo "deb https://dl.bintray.com/lightbend/deb stretch main" |     sudo tee /etc/apt/sources.list.d/lightbend.list && sudo apt-get install apt-transport-https -y &&     sudo apt-get update &&     sudo apt-get install -y reactive-cli

Now I added the version 1.6.1 at the end of the above string as I’ve downgraded my services to 1.6.1 due to these errors.