Request Entity Too Large and maxMemoryBuffer doesn't fix

Hi,

I’m getting Request Entity Too Large in a POST with application/x-www-form-urlencoded content type request. I have tried in application.conf all this:

play.http.parser.maxMemoryBuffer = infinite
akka.http.parsing.max-content-length = infinite
play.server.akka.max-content-length = infinite
play.server.akka.http.parsing.max-content-length= infinite

but still getting the BadRequest, any tip please ?

Hi @tbarros,

Which version of Play are you using? Are you getting a HTTP 400 or 413? Do you have a HTTP proxy (like nginx) in front of your application?

Best.

Hi Marcos

I’m so sorry, I was cheking the info to answer you and I realized I was setting the maxMemoryBuffer in the wrong server. Everything is working right now, thanks a lot for your reply.

1 Like