Sbt-hbs is not available in scala_2.12/sbt_1.0

(Ahimanikya) #1

I am using sbt-hbs - when I am trying to migrate to play 2.7.1, I am getting the following error - please help me to resolve this.

warn] module not found: com.bicou.sbt#sbt-hbs;1.0.5
[warn] ==== typesafe-ivy-releases: tried
[warn] https://repo.typesafe.com/typesafe/ivy-releases/com.bicou.sbt/sbt-hbs/scala_2.12/sbt_1.0/1.0.5/ivys/ivy.xml
[warn] ==== sbt-plugin-releases: tried
[warn] https://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/com.bicou.sbt/sbt-hbs/scala_2.12/sbt_1.0/1.0.5/ivys/ivy.xml
.
.
.
[warn] ==== sbt-hbs-repo: tried
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] :: UNRESOLVED DEPENDENCIES ::
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] :: com.bicou.sbt#sbt-hbs;1.0.5: not found
[warn] ::::::::::::::::::::::::::::::::::::::::::::::

(Ignasi Marimon-Clos) #2

Hi @ahimanikya,

It looks like there’s been no activity on https://github.com/bicouy0/sbt-hbs for few years now. It’s possible it doesn’t support sbt 1.0.

Cheers,

(Ahimanikya) #3

Thanks. Since our project depends on this and it won’t be easy for us to remove it. So is my best option - can I fork the git and make it compatible to sbt 1.0 and publish? Please advise.

(Hungai Amuhinda) #4

Hi @ahimanikya

I think that’s your best option. The owner of the project doesn’t maintain it anymore as captured on this Github issue https://github.com/bicouy0/sbt-hbs/issues/4

2 Likes