Scala sbt build failure due to version incompatibility or ssl certificate

Hello Team - While building the scala play project using sbt, I encountered the below issue: I suspect the issue could be because of the following reason:

  1. I am behind the proxy firewall and I have configured the proxy properly

  2. My plugins.sbt contains the following:
    resolvers += “Typesafe repository” at “http://repo.typesafe.com/typesafe/releases/
    resolvers += “TAMU Release Repository” at “Repository - Nexus Repository Manager
    addSbtPlugin(“com.typesafe.play” % “sbt-plugin” % “2.8.2”)

  3. I have installed all the below required certificates in intellij:
    repo1.maven.org
    *.jfrog.io
    *.cloudsmith.io
    *.library.tamu.edu

3)build.sbt contains the following:
version := “1.1.4”
lazy val root = (project in file(".")).enablePlugins(PlayJava)

scalaVersion := “2.13.1”

libraryDependencies += guice
//libraryDependencies ++= Seq(evolutions, jdbc)

libraryDependencies ++= Seq(
//“org.springframework.ldap” % “spring-ldap-core” % “1.3.1.RELEASE” ,
“org.springframework.ldap” % “spring-ldap-core” % “2.3.1.RELEASE” ,
//“org.hibernate” % “hibernate-entitymanager” % “3.6.9.Final”,
javaJpa, “org.hibernate” % “hibernate-core” % “5.4.9.Final”,
“org.springframework” % “spring-context” % “4.3.5.RELEASE” ,
//“org.springframework” % “spring-context” % “5.2.6.RELEASE” ,
“javax.persistence” % “javax.persistence-api” % “2.2”,
“commons-collections” % “commons-collections” % “3.2.1”
// “com.oracle” % “ojdbc7” % “12.1.0.2”,
//“com.h2database” % “h2” % “1.4.192”
)


Error Log
[warn] insecure HTTP request is deprecated ‘http://repo.typesafe.com/typesafe/releases/’; switch to HTTPS or opt-in as (“Typesafe repository” at “http://repo.typesafe.com/typesafe/releases/”).withAllowInsecureProtocol(true)
[warn] insecure HTTP request is deprecated ‘http://repo.typesafe.com/typesafe/releases/’; switch to HTTPS or opt-in as (“Typesafe repository” at “http://repo.typesafe.com/typesafe/releases/”).withAllowInsecureProtocol(true)
[warn] insecure HTTP request is deprecated ‘http://repo.typesafe.com/typesafe/releases/’; switch to HTTPS or opt-in as (“Typesafe repository” at “http://repo.typesafe.com/typesafe/releases/”).withAllowInsecureProtocol(true)
[warn]
[warn] Note: Some unresolved dependencies have extra attributes. Check that these dependencies exist with the requested attributes.
[warn] com.typesafe.play:sbt-plugin:2.8.2 (sbtVersion=1.0, scalaVersion=2.12)
[warn]
[warn] Note: Unresolved dependencies path:
[error] sbt.librarymanagement.ResolveException: Error downloading com.typesafe.play:sbt-plugin;sbtVersion=1.0;scalaVersion=2.12:2.8.2
[error] Not found
[error] Not found
[error] not found: https://repo1.maven.org/maven2/com/typesafe/play/sbt-plugin_2.12_1.0/2.8.2/sbt-plugin-2.8.2.pom
[error] not found: C:\Users\JHAWAK01.ivy2\local\com.typesafe.play\sbt-plugin\scala_2.12\sbt_1.0\2.8.2\ivys\ivy.xml
[error] not found: https://maven.library.tamu.edu/content/repositories/releases/com/typesafe/play/sbt-plugin_2.12_1.0/2.8.2/sbt-plugin-2.8.2.pom
[error] download error: Caught javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target (sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target)

Try to substitute:

addSbtPlugin(“com.typesafe.play” % “sbt-plugin” % “2.8.2”)

with

addSbtPlugin(“com.typesafe.play” % “sbt-plugin” % “2.8.13”)

Hi - Thanks for your reply, But still getting the same issue during the build from Windows Intellij