Seed project doesn't work


(Gordon Vidaver) #1

Hi,
Maybe this is a newbie thing but when I try to run the seed project I get the following. I believe I have my proxy set up correctly.
Thanks,
Gordon

$:blank me$ sbt new playframework/play-scala-seed.g8
[info] Set current project to blank (in build file:/Users/me/blank/)
[info] Set current project to blank (in build file:/Users/me/blank/)

This template generates a Play Scala project

name [play-scala-seed]:
organization [com.example]:

Template applied in /Users/me/blank/./play-scala-seed

...:blank me$ cd play-scala-seed/
...:play-scala-seed me$ sbt run
[info] Loading settings for project play-scala-seed-build from plugins.sbt,scaffold.sbt ...
[info] Loading project definition from /Users/me/blank/play-scala-seed/project
[info] Updating ProjectRef(uri("file:/Users/me/blank/play-scala-seed/project/"), "play-scala-seed-build")...
[warn]          module not found: com.typesafe.play#sbt-plugin;2.6.20
[warn] ==== local: tried
[warn]   /Users/me/.ivy2/local/com.typesafe.play/sbt-plugin/scala_2.12/sbt_1.0/2.6.20/ivys/ivy.xml
[warn] ==== local-preloaded-ivy: tried
[warn]   /Users/me/.sbt/preloaded/com.typesafe.play/sbt-plugin/2.6.20/ivys/ivy.xml
[warn] ==== local-preloaded: tried
[warn]   file:////Users/me/.sbt/preloaded/com/typesafe/play/sbt-plugin_2.12_1.0/2.6.20/sbt-plugin-2.6.20.pom
[warn] ==== public: tried
[warn]   https://repo1.maven.org/maven2/com/typesafe/play/sbt-plugin_2.12_1.0/2.6.20/sbt-plugin-2.6.20.pom
[warn] ==== sbt-maven-releases: tried
[warn]   https://repo.scala-sbt.org/scalasbt/maven-releases/com/typesafe/play/sbt-plugin_2.12_1.0/2.6.20/sbt-plugin-2.6.20.pom
[warn] ==== sbt-maven-snapshots: tried
[warn]   https://repo.scala-sbt.org/scalasbt/maven-snapshots/com/typesafe/play/sbt-plugin_2.12_1.0/2.6.20/sbt-plugin-2.6.20.pom
[warn] ==== typesafe-ivy-releases: tried
[warn]   https://repo.typesafe.com/typesafe/ivy-releases/com.typesafe.play/sbt-plugin/2.6.20/ivys/ivy.xml
[warn] ==== sbt-ivy-snapshots: tried
[warn]   https://repo.scala-sbt.org/scalasbt/ivy-snapshots/com.typesafe.play/sbt-plugin/2.6.20/ivys/ivy.xml
[warn]   module not found: org.foundweekends.giter8#sbt-giter8-scaffold;0.11.0
[warn] ==== local: tried
[warn]   /Users/me/.ivy2/local/org.foundweekends.giter8/sbt-giter8-scaffold/scala_2.12/sbt_1.0/0.11.0/ivys/ivy.xml
[warn] ==== local-preloaded-ivy: tried
[warn]   /Users/me/.sbt/preloaded/org.foundweekends.giter8/sbt-giter8-scaffold/0.11.0/ivys/ivy.xml
[warn] ==== local-preloaded: tried
[warn]   file:////Users/me/.sbt/preloaded/org/foundweekends/giter8/sbt-giter8-scaffold_2.12_1.0/0.11.0/sbt-giter8-scaffold-0.11.0.pom
[warn] ==== public: tried
[warn]   https://repo1.maven.org/maven2/org/foundweekends/giter8/sbt-giter8-scaffold_2.12_1.0/0.11.0/sbt-giter8-scaffold-0.11.0.pom
[warn] ==== sbt-maven-releases: tried
[warn]   https://repo.scala-sbt.org/scalasbt/maven-releases/org/foundweekends/giter8/sbt-giter8-scaffold_2.12_1.0/0.11.0/sbt-giter8-scaffold-0.11.0.pom
[warn] ==== sbt-maven-snapshots: tried
[warn]   https://repo.scala-sbt.org/scalasbt/maven-snapshots/org/foundweekends/giter8/sbt-giter8-scaffold_2.12_1.0/0.11.0/sbt-giter8-scaffold-0.11.0.pom
[warn] ==== typesafe-ivy-releases: tried
[warn]   https://repo.typesafe.com/typesafe/ivy-releases/org.foundweekends.giter8/sbt-giter8-scaffold/0.11.0/ivys/ivy.xml
[warn] ==== sbt-ivy-snapshots: tried
[warn]   https://repo.scala-sbt.org/scalasbt/ivy-snapshots/org.foundweekends.giter8/sbt-giter8-scaffold/0.11.0/ivys/ivy.xml
[warn]   ::::::::::::::::::::::::::::::::::::::::::::::
[warn]   ::          UNRESOLVED DEPENDENCIES         ::
[warn]   ::::::::::::::::::::::::::::::::::::::::::::::
[warn]   :: com.typesafe.play#sbt-plugin;2.6.20: not found
[warn]   :: org.foundweekends.giter8#sbt-giter8-scaffold;0.11.0: not found
[warn]   ::::::::::::::::::::::::::::::::::::::::::::::
[warn]
[warn]  Note: Some unresolved dependencies have extra attributes.  Check that these dependencies exist with the requested attributes.
[warn]        com.typesafe.play:sbt-plugin:2.6.20 (scalaVersion=2.12, sbtVersion=1.0)
[warn]                                            org.foundweekends.giter8:sbt-giter8-scaffold:0.11.0 (scalaVersion=2.12, sbtVersion=1.0)
[warn]
[warn]  Note: Unresolved dependencies path:
[warn]        com.typesafe.play:sbt-plugin:2.6.20 (scalaVersion=2.12, sbtVersion=1.0) (/Users/me/blank/play-scala-seed/project/plugins.sbt#L1-2)
[warn]                                              +- default:play-scala-seed-build:0.1.0-SNAPSHOT (scalaVersion=2.12, sbtVersion=1.0)
[warn]                                                 org.foundweekends.giter8:sbt-giter8-scaffold:0.11.0 (scalaVersion=2.12, sbtVersion=1.0) (/Users/me/blank/play-scala-seed/project/scaffold.sbt#L5-6)
[warn]                                                                                                       +- default:play-scala-seed-build:0.1.0-SNAPSHOT (scalaVersion=2.12, sbtVersion=1.0)
[error] sbt.librarymanagement.ResolveException: unresolved dependency: com.typesafe.play#sbt-plugin;2.6.20: not found
[error] unresolved dependency: org.foundweekends.giter8#sbt-giter8-scaffold;0.11.0: not found

(Marcos Pereira) #2

Hum, this can be a temporary thing on your side since I can see the files here:

https://bintray.com/playframework/sbt-plugin-releases/play-sbt-plugin/2.6.20#files/com.typesafe.play%2Fsbt-plugin

Or maybe you are using a proxy? If so, see the sbt reference here:

https://www.scala-sbt.org/1.x/docs/Setup-Notes.html#HTTP%2FHTTPS%2FFTP+Proxy

Best.