Ugrading to newest version of play

(Jose) #1

I am trying to upgrade to the latest version of play framework. However, I am getting a lot of problems. My sbt file includes:

libraryDependencies ++= Seq(
  cache,
  ws,
  evolutions,
  specs2,
  "com.softwaremill.macwire" %% "macros" % "2.2.5" % "provided",
  "com.softwaremill.macwire" %% "util" % "2.2.0",  
  "ch.qos.logback"  %  "logback-classic"   % "1.1.7",
  "de.svenkubiak" % "jBCrypt" % "0.4.1",
  "org.scalatestplus.play" %% "scalatestplus-play" % "1.5.0" % "test",
  "org.mockito" % "mockito-core" % "2.0.45-beta" % "test",
  "mysql" % "mysql-connector-java" % "5.1.34",
  "org.postgresql" % "postgresql" % "9.4.1207.jre7",
  "com.vividsolutions" % "jts" % "1.13",
  "com.typesafe.play" %% "play-slick" % "2.0.0",
  "com.typesafe.play" %% "play-slick-evolutions" % "2.0.0",
  "com.github.tminglei" %% "slick-pg" % "0.12.1",
  "com.github.tminglei" %% "slick-pg_date2" % "0.12.1",
  "com.github.tminglei" %% "slick-pg_play-json" % "0.12.1",
  "org.scalikejdbc" %% "scalikejdbc" % "2.4.2",
  "org.scalikejdbc" %% "scalikejdbc-config" % "2.4.2",
  "io.circe"          %% "circe-core"        % circeVersion,
  "io.circe"          %% "circe-generic"     % circeVersion,
  "io.circe"          %% "circe-parser"      % circeVersion,
  "io.circe"          %% "circe-jawn"        % circeVersion,
  "com.typesafe.akka" %% "akka-stream-kafka" % "0.14",
  "com.typesafe.akka" %% "akka-slf4j" % "2.4.0",
  "joda-time" % "joda-time" % "2.9.9",
  "org.joda"  % "joda-convert"  % "1.8.2",
  "net.debasishg" %% "redisclient" % "3.4",
  "commons-io" % "commons-io" % "2.5",
  "ch.qos.logback" % "logback-classic" % "1.1.8",
  "com.typesafe.scala-logging" %% "scala-logging" % "3.5.0",
  "org.typelevel" %% "cats-core" % "1.4.0",
  "com.github.julien-truffaut" %%  "monocle-core"  % monocleVersion,
  "com.github.julien-truffaut" %%  "monocle-macro" % monocleVersion,
  "com.github.julien-truffaut" %%  "monocle-law"   % monocleVersion % "test"
)

Any suggestions, please?

Thanks

(Patrick Li) #2

Perhaps a bit more details on what your problems are? Error output?

1 Like
(Marcos Pereira) #3

This. :-)

Also, I can already see that are a bunch of other dependencies that you must update, like play-slick, scalatest, and Akka. But again, as @chrono_b said, better to know what is happening.

Best.