Update with warning


(kimseng sieng) #1

Dear Sir,
I have downloaded the play framework java example and start update, it show me the warning.
How can solve to remove warning?
Thanks
[warn] Found version conflict(s) in library dependencies; some are suspected to be binary incompatible:
[warn] * com.google.guava:guava:22.0 is selected over {19.0, 20.0}
[warn] ± com.typesafe.play:play_2.12:2.6.15 () (depends on 22.0)
[warn] ± org.reflections:reflections:0.9.11 (depends on 20.0)
[warn] ± com.google.inject:guice:4.1.0 (depends on 19.0)
[warn] * com.typesafe.akka:akka-stream_2.12:2.5.11 is selected over 2.4.20
[warn] ± com.typesafe.play:play-streams_2.12:2.6.15 () (depends on 2.5.11)
[warn] ± com.typesafe.akka:akka-http-core_2.12:10.0.13 () (depends on 2.4.20)
[warn] * com.typesafe.akka:akka-actor_2.12:2.5.11 is selected over 2.4.20
[warn] ± com.typesafe.play:play_2.12:2.6.15 () (depends on 2.5.11)
[warn] ± com.typesafe.akka:akka-stream_2.12:2.5.11 () (depends on 2.5.11)
[warn] ± com.typesafe.akka:akka-slf4j_2.12:2.5.11 () (depends on 2.5.11)
[warn] ± com.typesafe.akka:akka-parsing_2.12:10.0.13 () (depends on 2.4.20)
[warn] Run ‘evicted’ to see detailed eviction warnings
[success] Total time: 4 s, completed Jun 6, 2018 8:00:50 AM