Upgrade Play 2.4 to 2.5 path error


#1

The upgrade from 2.4 to 2.5 is taking a long time, so much to change, but I am stuck now with one thing and can’t find help from Google.

I am getting this error when booting up the application.

These classes seem to be Play specific, not sure if I missed some step or what could cause the problem.

play.http.requestHandler [class java.lang.Class}] does not implement interface play.api.http.HttpRequestHandler or interface play.http.HttpRequestHandler.

#2

I found out the issue, I had an old requestHandler that was used in Play 2.4 in application.conf

play.http.requestHandler = "handlers.AuthorizationHandler"

Commented this out and it worked