Which minimal Kubernetes version is required

The Cloudflow deployment uses some “newer” Kubernetes technologies (plug-ins, CRD’s ?). From which Kubernetes version (1.x ?) is the deployment supported?

We are currently on OpenShift 3.10, which has kubernetes 1.10 under the hood … So, that might be problematic. Of course, we will upgrade “eventually” …

Thanks,

Peter V

Hi Peter,

We currently run on versions 1.11 and greater. Is there something in particular preventing you from upgrading?

Craig

Cloudflow does indeed extensively build on CRDs and operators. We have thoroughly tested it on Openshift 3.11 and 4.1. Openshift 3.10 will indeed be problematic due to it not supporting CRDs.

I hope you will be able to upgrade your clusters to a more recent version of Openshift. The installer and upgrade support in Openshift 4.x is orders of magnitude better than in Openshift 3.x but to get there you will unfortunately have to bite the bullet.

Age

Thanks for the very relevant information on exact required versions of OpenShift and Kubernetes.

We will see internally how to handle this.

Peter V