Increasing read timeout to avoid “Connection reset by peer”

Full discloser: This is a double post of this un-answered question in search of more and wise eyes.

I have a Scala Play(2.6.25) application. Based on directions here, I am attempting to set the read timeout to 3 minutes using the following configuration(application.conf):

play {
  server {
    akka {
      bindTimeout = 180 seconds
      requestTimeout = infinite
    }
  }
}

play {
  server {
    http {
      idleTimeout = 180 seconds
    }
  }
}

But the client’s connection is broken by the server at about 1 minute 16 seconds.

Request:

time curl --location --request POST 'http://localhost:9000/...' \
--header 'Content-Type: application/json' \
--header 'Cookie: JSESSIONID=78F3E25401A2631ABBE1006201AC1103' \
--max-time 180 \
--verbose \
--data-raw '{
   ...
}'

Response:

Note: Unnecessary use of -X or --request, POST is already inferred.
*   Trying ::1...
* TCP_NODELAY set
* Connected to localhost (::1) port 9000 (#0)
> POST /... HTTP/1.1
> Host: localhost:9000
> User-Agent: curl/7.54.0
> Accept: */*
> Content-Type: application/json
> Cookie: JSESSIONID=78F3E25401A2631ABBE1006201AC1103
> Content-Length: 1300
> Expect: 100-continue
>
< HTTP/1.1 100 Continue
< Date: Wed, 07 Oct 2020 18:24:32 GMT
* We are completely uploaded and fine
* Recv failure: Connection reset by peer
* stopped the pause stream!
* Closing connection 0
curl: (56) Recv failure: Connection reset by peer
curl --location --request POST  --header 'Content-Type: application/json'      0.01s user 0.01s system 0% cpu 1:16.11 total

Filters are disabled ( play.filters.enabled = [] ).

Appreciate any pointers on what I could be doing wrong.